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Mallando con Gmsh 
En este tutorial vamos a aprender a realizar una malla. Para esto necesitamos crear la geometría que se desea 
mallar. Veremos los pasos a seguir para poder llevar a cabo la malla, sea bidimensional o tridimensional. 

Creación de archivo 
1) En la carpeta deseada crear un archivo de texto en blanco. Nombrarlo “nombre.geo”. Puede realizarse a 

través de la terminal escribiendo “touch nombre.geo”. 
 

2) Abrir este archivo en Gmsh. Puede realizarse a través de la terminal escribiendo “gmsh nombre.geo”. 
 

Trabajo en Gmsh 
Comentarios generales: 
 
Mouse 

 
El click izquierdo rota el plano. 
El click derecho desplaza la pantalla. 
La ruedita hace zoom. 
 
Selección de elementos 
 
Cada vez que se selecciona un elemento (ej: punto, línea, etc.) se pone color rojo. 
 
Si el click no selecciona los elementos, verificar si en la parte inferior izquierda de la ventana la letra “S” tiene un 
recuadro color rojo, de ser así hacer click en ella y luego continuar con la selección normalmente. (Esto se activa o 
desactiva con la tecla “​Esc​​”, ​no presionarla por error​). 

 

 
 

Si se desea ​modificar o eliminar​ algún elemento ​en el editor de texto​​, se debe guardar el archivo y luego para 
poder ​visualizar​ el cambio ​en Gmsh​​:  

Modules -> Geometry -> Reload Script. 
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Si se desea ​modificar o eliminar​ algún elemento ​en Gmsh​​, para poder ​visualizarlo​ ​en el editor de texto​​, ir a la 
ventana correspondiente a dicho programa donde aparecerá la opción de recargar o descartar dicha modificación, 
de no ser así, cerrar sin guardar y volver a abrir el archivo. 

 
Atajos de Teclado 

 
No funciona Ctrl+C, Ctrl+V, Ctrl+Z, Ctrl+Y,  Ctrl+X, ni Supr.  
Es decir, no se puede copiar, pegar, deshacer, rehacer, cortar, o borrar con el teclado, debe realizarse mediante los 
comandos explicados en los pasos correspondientes.  
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Creación de geometría 
 
● Puntos 

 
1) Crear​ punto ​en Gmsh​​: 

 
Presionar los siguientes comandos en la ventana izquierda del programa: 

Modules -> Geometry -> Elementary entities -> Add -> Point 
 
Se abre una ventana (“Elementary Entity Context”) y en la solapa “Point” ingresamos las coordenadas del 
punto: x,y,z; también aparece “Prescribed mesh element size at point” como 4to elemento. Se trata del 
paso del mallado (cuanto más pequeño sea, más densa va a ser la malla contigua a ese punto). 
 
Tocando la tecla “ENTER” (o clickeando en add) se agrega el punto elegido. 

 

Nota: Tener cuidado con el cursor del mouse, si se mueve fuera de la ventana de Elementary Entity Context 

se modifican los valores que se hayan puesto en las coordenadas.  
 
También puede seleccionarse con el cursor del mouse ubicándolo en la posición deseada y presionando la 
tecla “e”.  
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2)  ​Crear​ punto ​en el editor de texto  
 
Abrir el archivo y escribir: 
  Point (1) = {x,y,z,k}; 
 
 donde x, y , z serán las coordenadas del punto, y k será el paso del mallado explicado en el punto 1 de esta 
sección. 
 

Nota: No olvidar recargar el archivo en Gmsh para visualizar. (Reload Script en comentarios generales). 

 
 

3)  ​Modificar​ el punto ​en Gmsh  
 
Presionar los siguientes comandos en la ventana izquierda del programa: 

Modules -> Geometry -> Elementary entities -> Translate -> Point  
 
Se abre nuevamente la ventana (“Elementary Entity Context”), pero esta vez en la solapa “Translation”. 
 
Seleccionar con click izquierdo el punto deseado (recordar que una vez seleccionado se pone color rojo) y 
determinar las nuevas coordenadas, presionar “e” para terminar la modificación de un punto, una vez 
modificados todos los deseados presionar “q”. 
 

Nota: No se puede modificar la coordenada “k” correspondiente al mallado de este modo. Para hacerlo puede 

eliminarse el punto (pasar al punto 5 de esta sección) y volver a crearlo (volver al punto 1 o 2 de esta sección), 

o modificarlo en el editor de texto (pasar al punto 4 de esta sección). 

 

 
 
 

 
4)  Modificar​ el punto ​en el editor de texto 

 
Abrir el archivo y modificar como se deseen las coordenadas previamente escritas. 
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5)  ​Eliminar​ el punto ​en Gmsh   
 
Presionar los siguientes comandos en la ventana izquierda del programa: 

Modules -> Geometry -> Elementary entities -> Delete -> Point 
 
Seleccionar con click izquierdo todos los puntos que desee borrar y presionar “e” para terminar y “q” para 
salir. 
 
 

 
 
 
6)  ​Eliminar​ el punto ​en editor de texto   
 

Simplemente borrar todo el comando del punto definido que desea eliminarse. 
 

Nota: No olvidar recargar el archivo en Gmsh para visualizar. (Reload Script en comentarios generales). 

 

 

 

● Línea Recta entre dos puntos  
 

Nota: Los puntos deben estar previamente definidos, de no ser así, retomar los pasos correspondientes a la 

sección “Puntos”. 

 
1) Crear​ línea ​en Gmsh 

 
Presionar los siguientes comandos en la ventana izquierda del programa: 

Modules -> Geometry -> Elementary entities -> Add -> Straight Line 
 
Hay que seleccionar los puntos entre los cuales va a crear una línea, el de inicio (recordar que se pone rojo 
una vez seleccionado) y luego el de fin. Para desseleccionar el punto de inicio presionar “u”. Para  
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Ejemplo de resultado obtenido: 
 

 
 
 
 

    2)  ​Crear​ línea ​en editor de texto 
 

Abrir el archivo de texto y escribir: 
Line (1) = {3,2};  
 

donde 3 y 2 serían los puntos llamados 3 y 2 (que deben estar previamente enunciados con sus 
correspondientes coordenadas).  
 

Nota: No olvidar recargar el archivo en Gmsh para visualizar. (Reload Script en comentarios generales). 

 

Para poder ​visualizar​ los nombres de los puntos ​en Gmsh​​, presionar los siguientes comandos en la barra 
superior de la ventana del programa: 

 Tools -> Options -> Geometry -> Options 
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Se abre una ventana (“Options - General”) y debemos seleccionar la solapa de visualización de la geometría. 
Para realizarlo se debe seleccionar el segundo ítem del listado a la izquierda de la ventana “Geometry” y la 
solapa “Visibility”, donde se debe tildar la opción “Point Labels”. Aparecerán entonces los nombres al lado 
de cada punto. 
 
 

 
 

 
3)  ​Eliminar​ línea ​en Gmsh​​ (del mismo modo que los puntos) 
 

Presionar los siguientes comandos en la ventana izquierda del programa: 
Modules -> Geometry -> Elementary entities -> Delete -> Line 

 
Seleccionar con click izquierdo todas las líneas que desee borrar y presionar “e” para terminar y “q” para 
salir. 

 
 

4)  ​Eliminar​ el punto ​en editor de texto   
 

Simplemente borrar todo el comando de la línea definida que desea eliminarse. 
 

Nota: No olvidar recargar el archivo en Gmsh para visualizar. (Reload Script en comentarios generales). 
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● Arco de Círculo entre dos puntos con un punto central (como centro de 
circunferencia) 
 

1) Crear​ arco de círculo ​en Gmsh 
 

Presionar los siguientes comandos en la ventana izquierda del programa: 
Modules -> Geometry -> Elementary entities -> Add -> Circle arc 

 
Hay que seleccionar los puntos en el siguiente orden: 1° punto inicial (recordar que se pone rojo una vez 
seleccionado), 2° punto central, 3° punto final. 
 

Nota: Se debe tener en cuenta que genera el arco de círculo en sentido antihorario para determinar el orden de 

los puntos que van a conformar la circunferencia y el centro de la misma. 

 

Ver la aclaración a continuación de la imagen. 
 

 
 

Aclaración:​ ​Para que sea un arco, se deben definir los puntos de inicio (1°)  y fin (3°) a la misma distancia del 

punto del centro (2°), es decir el radio. De lo contrario en la parte inferior de la ventana figura en rojo un error y 

lo dibuja circular hasta la intersección de la circunferencia que pasa por el punto de inicio con radio igual a la 

distancia al centro de dicho punto, con una recta radial desde el centro que pase por el punto mal indicado como 

final. 
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2)  ​Crear​ arco de círculo ​en editor de texto 
 

Abrir el archivo de texto y escribir: 
Circle (1) = {1,2,3}; 
 

donde 1, 2 y 3 son los nombres de los puntos definidos anteriormente. 
 

Nota: No olvidar recargar el archivo en Gmsh para visualizar. (Reload Script en comentarios generales). 
 

 
3)  Para conformar un ​círculo completo​ se deben definir en 4 arcos de un cuarto de circunferencia si se desea 

extrudar (dar profundidad) correctamente. De otro modo van a aparecer  errores marcados en rojo en la 
parte inferior de la ventana, y no va a ser extrudado como un cilindro. 
 

 

● Superficie Plana 
 
Nota : Para crear una superficie se debe tener un polígono cerrado. De otro modo no se podrá generar ninguna 

superficie. De no haber definido el polígono de partida, retomar pasos de “Puntos”, “Líneas”, o “Arco de 

Círculo”. 

 

1) Crear​ superficie plana ​en Gmsh 
 

Presionar los siguientes comandos en la ventana izquierda del programa: 
Modules -> Geometry -> Elementary entities -> Add -> Plane surface 

 
Se debe seleccionar el contorno de la superficie deseada (siendo un contorno cerrado no hace falta clickear 
en todas las líneas que lo compongan, se selecciona todo automáticamente), recordar que se pone en rojo 
una vez seleccionada.  
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Ejemplo: 

 
 

Presionar “e” para realizar, “q” para salir. Una vez definida se generan unos ejes punteados internos que 
determinan la superficie. 

 
A continuación se encuentra el resultado obtenido para el ejemplo: 
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2) ​Crear​ superficie plana ​en editor de texto  
 

Abrir el archivo y escribir: 
Line Loop (5) = {3,4,1,2}; Plane Surface (6) = {5};  
 

donde “line loop” genera un polígono entre las líneas 3,4,1 y 2.  
 
Para ​visualizar​ los nombres de las líneas ​en Gmsh​​, del mismo modo que en el punto 2 correspondiente a la 
sección “​Puntos”​, presionar los siguientes comandos en la barra superior de la ventana del programa: 

 Tools -> Options -> Geometry -> Visibility 
 
Se abre la ventana “Options - Geometry” , seleccionar  “Geometry” en la columna izquierda, y en la solapa 
“Visibility” tildar la opción “Line Labels”. 
 
   Nota: No olvidar recargar el archivo en Gmsh para visualizar. (Reload Script en comentarios generales). 
 
 

● Extrusión 
 

1) Extrudar​ una superficie en determinada dirección ​en Gmsh  
 
Nota: la superficie debe estar previamente definida. 

 

Presionar los siguientes comandos en la ventana izquierda del programa: 
Modules -> Geometry -> Elementary entities -> Translate -> Extrude Surface  

 
Se debe seleccionar la superficie que se desea extrudar. Para seleccionarla hacer click izquierdo sobre los 
ejes punteados nombrados anteriormente. Se abre una ventana (“Elementary Entity Context”) y en la solapa 
“Translation” se debe seleccionar cuánto y en qué dirección se desea extrudar la superficie seleccionada, por 
ejemplo: 1 unidad en componente “z”. La superficie seleccionada se pone en rojo (sus líneas punteadas).  

 
Aclaración: tener cuidado en qué plano se encuentra la figura inicial y en qué dirección se desea extrudar.  
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Para realizar presionar “e”, “q” para salir.  
 

Recordar: para rotar el plano se utiliza el click izquierdo, para desplazar el derecho. 

 

 
 
Esta superficie extrudada no va a poder ser mallada de manera estructurada correctamente a menos que 
se seleccionen las capas deseadas y se recombine. Es más simple realizarlo en el editor de texto (pasar al 
paso 2 de esta sección). De encontrarse en el caso de desear una malla estructurada dirigirse a la sección 
correspondiente a Malla Estructurada.  
 

Nota: Es recomendable realizar los pasos de “estructuración”  de todas las líneas y superficies ​antes de 

extrudar​ para evitar tener que “estructurar” las nuevas líneas y superficies que surgen al darle profundidad a 

la figura. De este modo, todas aquellas se encontrarán “estructuradas” del mismo modo que se realice la 

figura a extrudar. Para ello dirigirse a la sección de “Creación de Malla Adquisidora de Datos - Malla 

Estructurada”. 
 
2) ​Extrudar​ la superficie plana en el ​editor de texto 
 
Abrir el archivo y escribir: 

Extrude {0, 0, 1} {Surface{6};}  
 

donde los primeros valores entre llaves son las coordenadas x, y, z en las que se desea extrudar (en este 
caso 1 unidad en eje z), y el número que se encuentra dentro del comando “Surface” debe coincidir con el 
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número con que se denominó la superficie anteriormente creada (en este caso “6”). Esto genera un cuerpo 
que será mallado de manera no estructurada. 
 

Recordar: Tener cuidado con el plano en el que se encuentra la figura y en qué plano se desea extrudar la 

misma. Para ver el resultado girar el plano con el click derecho. 

 
Para que la superficie extrudada pueda ser mallada de manera estructurada, el comando en el editor de 
texto debe ser: 

Extrude {0, 0, 1} {Surface{6};​ Layers{10}; Recombine;​} 
 

Donde 10 serán las capas en las que va a dividir la superficie extrudada para realizar la malla estructurada. 
Se puede escribir el número que se desee. 
 

Nota: en caso de haber realizado la ​extrusión​ ​en Gmsh​​, solamente debe editarse el comando que aparece en 

el editor de texto incorporando los resaltados en color rosa (“Layers y Recombine”).   
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Creación de Malla Adquisidora de Datos 

● No Estructurada  
 

Nota: La superficie debe estar definida previamente. De no ser así, retomar los pasos de la sección 

geometría que considere necesarios. 

 
 
 

Bidimensional 
 
Para realizar una malla bidimensional, presionar los siguientes comandos en la ventana izquierda del 
programa: 

 Modules->Mesh->2D  
 
La malla ​bidimensional no estructurada​​ utiliza triángulos como forma geométrica para realizar el 
mallado. 
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Tridimensional 
 

Para realizar una malla tridimensional, presionar los siguientes comandos en la ventana izquierda del 
programa: 
  Modules->Mesh->3D 

 
La malla ​tridimensional no estructurada​​ utiliza tetraedros como forma geométrica para realizar el 
mallado. 

 
 

A ​diferencia​ del mallado en ​dos dimensiones​​, en la malla ​tridimensional ​​se puede observar que se genera 
una malla interna en el volumen (en lugar de solo encontrarse en las caras). 
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● Estructurada 
Nota: La superficie debe estar definida previamente. De no ser así, retomar los pasos de la sección 

geometría que considere necesarios. 

 
 
 

Bidimensional 
 
A ​diferencia​ de la malla bidimensional ​no estructurada​​, la estructurada utiliza cuadrados como forma 
geométrica para realizar el mallado. 
 
Para realizar una malla ​estructurada​​ debemos indicar qué líneas y superficies deseamos estructurar, para 
ello, presionar los siguientes comandos en la ventana izquierda del programa:  

Modules -> Mesh -> Define -> Transfinite -> Line.  
 
Se abre una ventana llamada “Mesh Context”.  Dentro de la solapa “Transfinite Line”  se encuentra un 
casillero que dice  “Number of points”, esto será la cantidad de puntos que definirán las divisiones que 
tendrá dicha línea.  
Luego, en el casillero llamado “Type” se puede seleccionar: 

 “Progression” o “Bump” 
  
Selección “Progression” 
Se trata de un parámetro de progresión con que se dividirán las capas de la malla de manera proporcional 
al mismo, partiendo la/s línea/s seleccionadas. Se utiliza del siguiente modo: 

 “1” para una progresión uniforme. 
“1.1” genera una progresión de un 10% en la dirección que posea la línea. 
etc. 

 
Selección “Bump” 
Se trata de un parámetro de progresión con que se dividirán las capas de la malla de manera proporcional 
al mismo, desde el contorno hacia el centro de la superficie. Se utiliza del siguiente modo: 

 “1” para una progresión uniforme. 
“1.1” genera una progresión de un 10% en la dirección que posea la línea. 
etc. 

 
 
Una vez configurado se seleccionan las líneas “a estructurar” (pueden seleccionarse todas continuadas, 
pero no es recomendable para los casos en que se desee utilizar un parámetro distinto de 1. Recordar que 
se van poniendo rojas una vez seleccionadas) y presionar “e”. Si se selecciona una línea no deseada por 
error, presionar “q” para salir y comenzar nuevamente.  
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Debe realizarse el mismo procedimiento pero para las superficies. 
 

Nota: Las mismas deben estar previamente definidas.​ ​De no ser así, retomar los pasos de “Superficies” 

 
Para ello, presionar los siguientes comandos en la ventana izquierda del programa: 

Modules -> Mesh -> Define -> Transfinite -> Surface.  
 
Se abre nuevamente la ventana “Mesh Context”, pero en esta oportunidad en la solapa “Transfinite 
Surface”. En la misma aparece una opción para Transfinite arrangement: left/right/alternated. En este caso 
no nos afecta la opción elegida, ya que sirve para seleccionar la disposición de los triángulos, los cuales 
nosotros NO utilizaremos por tratarse de malla estructurada, y a continuación utilizaremos la opción de 
recombinar. 
 
Se selecciona una de las superficies a “estructurar”, recordar que se pone roja la superficie una vez 
seleccionada (sus líneas punteadas), éstas sí deben realizarse de a una por vez. Se presiona “e” para realizar 
y “q” para salir. Si se selecciona por error una superficie no deseada, presionar “q” para salir y volver a 
comenzar.   
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Luego, presionar los siguientes comandos en la ventana izquierda del programa: 

Modules->Define->Recombine 
 
Otra vez se debe seleccionar la superficie “a estructurar”. Recordar que también se pone roja la superficie 
una vez seleccionada (sus líneas punteadas). Se presiona “e” para realizar y “q” para salir.  
Nuevamente, si se selecciona por error una superficie no deseada, presionar “q” para salir y volver a 
comenzar. 
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Estos pasos se realizan tantas veces como superficies se deseen “estructurar” ya que no pueden 
seleccionarse todas juntas como las líneas. 
 
Luego mismo proceso que para ​Malla NO Estructurada​: 
 

Bidimensional 
 
Para realizar una malla bidimensional, presionar los siguientes comandos en la ventana izquierda del 
programa:  

Modules->Mesh->2D  
 
En el siguiente ejemplo puede observarse que se seleccionó solamente la cara frontal del cubo para 
realizar una ​malla estructurada​​, mientras que el resto del cubo posee una malla no estructurada: 
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Aclaración: Esto no funciona si se desea un parámetro de progresión distinto de 1, para el caso de un 

volumen, sí funcionará en una superficie plana. 

 
Tridimensional 

 
En el caso tridimensional, también debe indicarse cuáles líneas y superficies se desean “estructurar”. 
 

ATENCIÓN: Si se realiza por medio del archivo de texto, ​NO​ olvidar el paso de modificación en el mismo al 

extrudar. “Layers{10};Recombine;” 

 

Para realizar una malla ​tridimensional estructurada​​, presionar los siguientes comandos en la ventana 
izquierda del programa: 

 Modules->Mesh->3D 
 
La malla ​tridimensional estructurada​​ utiliza hexaedros como forma geométrica para realizar el mallado. 
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Solange Feldman, Lautaro Kamimura Varela UTN - FRH  CEDI         2018 



23/24 

Algunos Ejemplos 
1) Utilizando “Bump”  
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2) Utilizando “Progression” distinto de 1. 
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